Question 5600XT BIOS flashed with mod from Red BIOS Editor, there is an issue

ricardo

Neuling
Mitglied seit
Mrz 1, 2020
Beiträge
4
Punkte
1
Hello and thank you for everything. Currently, I have a 5600XT in which I have flashed the modified bios by Red BIOS Editor. However, the BIOS did not work, the system hangs during POST. This is no problem, I am used to flashing BIOS with SPI Programmer CH341a, I am free to test anything.

I think maybe this did not work due to the fact that my card is dual BIOS, and when I read the BIOS from the memory chip, it comes out with 1024kb, rather than the 512kb saved from GPU-Z. When I try to open this extracted BIOS with RBE, it modifies fine, but does not save by stating "An unknown error occurred when accessing (filename path). This is not a permission issue, I am running admin. It works fine to save the file when I use the GPUz extracted rom. However, even with the 512KB file, it does not work to post the card.

I have tried several things, the last one was to make only a very small change on the GFX Maximum Clock to 1900MHz. It still does not work. I originally made a BIOS with a lot more changes and limits, such as 2100, 1000 memory, more power, voltage, etc, etc. but decided to make a small alteration to see if it would work-- unfortunately it doesn't.

I have also tried to open in HxD the original long file 1024kb and noticed it makes no difference, because after 000FFFF0 it is only 0's anyway. Also, in HxD, I have tried to open the original stock BIOS and overwrite the part, leaving the correct file size, but this also did not work to POST. Stock BIOS still works fine when re-flashed, card is perfect.

So, I am leaving a link to my files, to see if we can figure out why the modified BIOS is not working on my 5600XT.
Here is the URL: http://xonedigital.com/BIOS_etc.zip
on this ZIP file, there are the following:
1 - 5600xt1_gpuz.rom (Original BIOS from the card extracted with GPU-Z)
2 - 5600xt-stock_extract.rom (This is the BIOS file extracted from the Chip with SPI Programmer, it loads on RBE, but fails to save)
3 - mpt-1900_only.mpt (This is an example of a small change I tried to see if it would work, only changing maximum clock to 1900mhz)
4 - 1900-ONLY-BIOS1.rom (This is the final outcome of RED BIOS EDITOR using the GPU-Z BIOS with the MorePowerTool settings of 1900mhz)

I hope this helps, thank you so much for all your work again and let me know if anything else is needed. I am really looking forward to free up the power of this 5600XT :)

Thanks again!
 

Igor Wallossek

Format©
Mitarbeiter
Mitglied seit
Jun 1, 2018
Beiträge
3.451
Punkte
114
Alter
55
Standort
Labor
Which Vendor?

I also tested a card with dual BIOS and got 512 KB. Strange. But the 5600 XT seems more tricky.
 

ricardo

Neuling
Mitglied seit
Mrz 1, 2020
Beiträge
4
Punkte
1
Which Vendor?

I also tested a card with dual BIOS and got 512 KB. Strange. But the 5600 XT seems more tricky.
It's an XFX card model RX-56XT6D. From GPU-Z it comes 512kb, but SPI Programmer reads 1024kb. Although as mentioned, it seems to be empty after 000FFFF0, so it could just well have been 512kb anyway. Or maybe the switch only allows half of the data to be seen at each time, I don't know, first time with dual bios card. It is a P25Q80H bios chip.

Looking forward to free up the power limits on it!
 

Igor Wallossek

Format©
Mitarbeiter
Mitglied seit
Jun 1, 2018
Beiträge
3.451
Punkte
114
Alter
55
Standort
Labor
#metoo :D

Let's wait for the community. I'm sure we'll found a solution. :D
 

snake43rus

Neuling
Mitglied seit
Mrz 1, 2020
Beiträge
3
Punkte
1
I also have a 5600XT card. After editing the BIOS and firmware, the screen is black. Waiting for an update) while restored the original)
 

Igor Wallossek

Format©
Mitarbeiter
Mitglied seit
Jun 1, 2018
Beiträge
3.451
Punkte
114
Alter
55
Standort
Labor
Sapphire RX 5700 Pulse, MSI RX 5700 XT Gaming X / Evoke.

The RX 5600 XT seems problematic. But BIOS editing was ok with the Powercolor RX 5600 XT Red Dragon
 
Oben Unten