Grundlagenartikel X570-Boards mit ECC-Unterstützung

tester5000

Neuling
Mitglied seit
Aug 15, 2019
Beiträge
4
Punkte
2
Aida sagt: ECC: Unterstützt, Aktiviert.

Sieht man sich das Posting dort an:

Dort wird auf einem Intel Workstation Board mit C236er Chipsatz ECC als unterstützt, aber als deaktiviert gekennzeichnet. Von daher könnte davon ausgegangen werden, dass irgendetwas positives, zumindest ansatzweise, auf X570 mit ECC passiert?
 

garfield36

Veteran
Mitglied seit
Jul 24, 2018
Beiträge
395
Punkte
27
Standort
Wien
Es gibt ja nicht nur AIDA64. Man kann auch mit der Windows PowerShell eruieren ob ECC vorhanden bzw. aktiv ist. Einfach in der PowerShell "wmic memphysical get memoryerrorcorrection" eingeben. Wird der Wert 3 ausgegeben steht ECC nicht zur Verfügung. Wird eine 5 angezeigt werden einzelne Bitfehler korrigiert. Bei 6 können auch Multibit-Fehler korrigiert werden. Ob das nun zwei oder mehr Bits sind, weiß ich allerdings nicht.
Irgendwo in diesem Thread wurde die Ausgabe über die PowerShell schon mal behandelt.
 

vlad_griboff

Neuling
Mitglied seit
Jul 27, 2020
Beiträge
1
Punkte
1
Also ich habe bei mir (R5 3600 + Asrock x570 Pro4) ECC durch RAM Übertaktung 2400 -> 3000 validieren können.

Unter Ubuntu 20.04:

[ 0.693613] EDAC MC: Ver: 3.0.0
[ 2.285115] EDAC amd64: Node 0: DRAM ECC enabled.
[ 2.285116] EDAC amd64: F17h_M70h detected (node 0).
[ 2.285160] EDAC MC: UMC0 chip selects:
[ 2.285160] EDAC amd64: MC: 0: 0MB 1: 0MB
[ 2.285161] EDAC amd64: MC: 2: 8192MB 3: 0MB
[ 2.285164] EDAC MC: UMC1 chip selects:
[ 2.285164] EDAC amd64: MC: 0: 0MB 1: 0MB
[ 2.285165] EDAC amd64: MC: 2: 8192MB 3: 0MB
[ 2.285165] EDAC amd64: using x16 syndromes.
[ 2.285165] EDAC amd64: MCT channel count: 2
[ 2.288933] EDAC MC0: Giving out device to module amd64_edac controller F17h_M70h: DEV 0000:00:18.3 (INTERRUPT)
[ 2.288947] EDAC PCI0: Giving out device to module amd64_edac controller EDAC PCI controller: DEV 0000:00:18.0 (POLLED)
[ 2.288948] AMD64 EDAC driver v3.5.0
[ 15.589673] EDAC MC0: 1 CE Cannot decode normalized address on mc#0csrow#2channel#1 (csrow:2 channel:1 page:0x0 offset:0x0 grain:64 syndrome:0x10)
[ 333.205407] EDAC MC0: 1 CE Cannot decode normalized address on mc#0csrow#2channel#1 (csrow:2 channel:1 page:0x0 offset:0x0 grain:64 syndrome:0x10)
[ 548.806668] EDAC MC0: 1 UE Cannot decode normalized address on mc#0csrow#2channel#1 (csrow:2 channel:1 page:0x0 offset:0x0 grain:64)
[ 660.885378] EDAC MC0: 1 CE on mc#0csrow#2channel#1 (csrow:2 channel:1 page:0x39e176 offset:0x960 grain:64 syndrome:0x10)
Memory controller events:
1 2020-05-25 22:15:17 +0200 1 Corrected error(s): Cannot decode normalized address at mc#0csrow#2channel#1 location: 0:2:1:-1, addr 0, grain 6, syndrome 16
2 2020-05-25 22:20:34 +0200 1 Corrected error(s): Cannot decode normalized address at mc#0csrow#2channel#1 location: 0:2:1:-1, addr 0, grain 6, syndrome 16
3 2020-05-25 22:24:10 +0200 1 Fatal error(s): Cannot decode normalized address at mc#0csrow#2channel#1 location: 0:2:1:-1, addr 0, grain 6, syndrome 0
4 2020-05-25 22:26:02 +0200 1 Corrected error(s): at mc#0csrow#2channel#1 location: 0:2:1:-1, addr 15537236320, grain 6, syndrome 16

No PCIe AER errors.

No Extlog errors.

Und noch ein Test mit MemTest86:
4858

4859
 
Oben Unten