Frage Fehlersuche SSD

Fleder

Mitglied
Mitglied seit
Nov 16, 2019
Beiträge
40
Punkte
8
Hallo zusammen,

Ich habe leider ein (für mich) größeres Problem.
Nach einem Windows 10 Update vom 17.06 bekam ich einen Bluescreen mit "WHEA_UNCORRECTABLE_ERROR" und mein System fand die SSD nicht mehr, auf der Windows läuft.

Nach einigem hin und her ließ sich Windows wieder booten, aber sobald ich einen Tag danach wieder arbeiten wollte und Internet am Rechner verfügbar war, kam natürlich erneut das Windows Update und nun bootet er gar nicht mehr ins OS, findet die Platte aber im BIOS.

Gibt es eine Möglichkeit rauszufinden, was defekt ist? Ob nun SSD oder eventuell etwas am Mainboard? Oder hat jemand gar einen Tipp, das ohne neue Hardwarekäufe vielleicht wieder hin zu bringen?

Weder das Qualität- noch das Funktionsupdate lassen sich deinstallieren.
Auch ein Wiederherstellungspunkt lässt sich nicht einspielen. Unbekannter Fehler bei der Systemwiederherstellung (0x800701b1).

Wäre über jede Hilfe dankbar. Grüße
 

LEIV

Urgestein
Mitglied seit
Aug 12, 2021
Beiträge
1.017
Punkte
83
Alter
31
Standort
Aschaffenburg
CrystalDiskInfo Downloaden, das sagt dir den Zustand der SSD
 

LEIV

Urgestein
Mitglied seit
Aug 12, 2021
Beiträge
1.017
Punkte
83
Alter
31
Standort
Aschaffenburg
Das sagt dir nur, wie es um die Festplatte steht...
hast du nen bootfähigen usb stick (mit Windows oder linux) ? damit sollte es ja dann alles überprüfbar sein
 

Fleder

Mitglied
Mitglied seit
Nov 16, 2019
Beiträge
40
Punkte
8
Das sagt dir nur, wie es um die Festplatte steht...
hast du nen bootfähigen usb stick (mit Windows oder linux) ? damit sollte es ja dann alles überprüfbar sein
Danke. Ja, das ist mir klar, aber als Laie dachte ich mir, dass ein eventueller Fehler am M2 Anschluss auf dem Mainboard vielleicht auch zu Fehlern beim Zugriff auf die SSD führen könnte. Daher die Frage, ob hier unterschieden werden kann, woher eventuelle lese/schreib Fehler rühren.
Ubuntu Live USB Stick erstellen und mal mit smartctl nachsehen. Wenn das über deinen Rechner nicht mehr geht, mal bei einem Freund nachfragen, ob du es dort machen kannst?
Danke. Ich mache mich mal dran einen zu erstellen und melde mich dann wieder.
 

Martin Gut

Urgestein
Mitglied seit
Sep 5, 2020
Beiträge
5.617
Punkte
113
Ja, das ist mir klar, aber als Laie dachte ich mir, dass ein eventueller Fehler am M2 Anschluss auf dem Mainboard vielleicht auch zu Fehlern beim Zugriff auf die SSD führen könnte. Daher die Frage, ob hier unterschieden werden kann, woher eventuelle lese/schreib Fehler rühren.
Ich denke auch, dass Fehler beim M.2-Anschluss zu Fehlern bei der SSD führen können. Die Verbindung zu einem Gerät muss ja immer auch funktionieren. CrystaDiskInfo zeigt recht genau an, welche Fehler aufgetaucht sind. Wenn man Glück hat, könnte das einen Hinweis auf die Ursache geben.

Falls es damit nicht klar wird, müsste man die SSD in einem anderen M.2-Slot oder in einem anderen PC testen.

Ein WEHA-Error deutet klar auf Hardwareprobleme hin. Es erstaunt mich aber doch etwas, dass es genau mit einem Windowsupdate zusammen fällt. Ich würde Windows auf einer anderen SSD/HD oder einem Stick neu installieren und schauen, ob es problemlos läuft.

Man könnte auch das Dateisystem und die Systemdateien von Windows überprüfen (mit Datenträgerverwaltung und sfc /scannow). Die Systemdateien überprüfen bringt aber natürlich erst etwas, wenn die SSD erkannt wird, startet und es später beim Booten oder im Betrieb abstürzt.
 

Fleder

Mitglied
Mitglied seit
Nov 16, 2019
Beiträge
40
Punkte
8
Ich denke auch, dass Fehler beim M.2-Anschluss zu Fehlern bei der SSD führen können. Die Verbindung zu einem Gerät muss ja immer auch funktionieren. CrystaDiskInfo zeigt recht genau an, welche Fehler aufgetaucht sind. Wenn man Glück hat, könnte das einen Hinweis auf die Ursache geben.

Falls es damit nicht klar wird, müsste man die SSD in einem anderen M.2-Slot oder in einem anderen PC testen.

Ein WEHA-Error deutet klar auf Hardwareprobleme hin. Es erstaunt mich aber doch etwas, dass es genau mit einem Windowsupdate zusammen fällt. Ich würde Windows auf einer anderen SSD/HD oder einem Stick neu installieren und schauen, ob es problemlos läuft.

Man könnte auch das Dateisystem und die Systemdateien von Windows überprüfen (mit Datenträgerverwaltung und sfc /scannow). Die Systemdateien überprüfen bringt aber natürlich erst etwas, wenn die SSD erkannt wird, startet und es später beim Booten oder im Betrieb abstürzt.
Also der SFC brachte folgende Meldung:
Windows Resource Protection could not perform the requested operation

Ich komme aber nicht in den abgesicherten Modus um das zu wiederholen, wie es Microsoft vorschlägt bei diesem Problem.

Parallel lasse ich gerade einen Windows Live Stick erstellen. Um dann mit CrystalDiskInfo die Platte checken zu lassen.

Ich komme per Eingabeaufforderung auf die SSD drauf. Sehe also die Ordnerstruktur etc. Aber Windows bootet nicht.

Meint ihr, es wär möglich und oder sinnvoll ein Image der SSD mit CloneZilla zu erstellen für eine neue SSD oder würde hier eventuell der "Fehler" mit übertragen? Und gäbe es hierfür eventuell ein Check Programm, dass dies erkennt?

Ich versuche nur herauszufinden, was ein sinnvoller Weg wäre, hier jetzt weiterzumachen.

Ich habe kein Problem damit, Windows neu aufzusetzen, ander natürlich wäre ich sehr an den Daten der SSD interessiert. Gerne auch am kompletten System, das hier einiges an Zeit zur Konfiguration investiert wurde.

Aber was nicht geht, geht eben nicht. Nur leider fehlt mir hier ein wenig die Erfahrung. Sorry, wenn ich euch damit hier Zeit Raube.
Danke jedenfalls trotzdem an alle, die ihre Zeit für mich opfern.

Edit: eventuell ist es für jemanden interessant. In der Eingabeaufforderung ist meine system SSD nun X statt C. Ich gehe davon aus dass das normal ist. Jedoch ist diese schreibgeschützt und verhindert daher CHKDSK.
Ist das hier immer der Fall oder ist der Schreibschutz eventuell das Problem?

Und weiter habe ich herausgefunden, dass meine richtige System Platte den Buchstaben D bekommen hat. Was X nun genau ist, keine Ahnung. Bei D funktioniert der SFC aber auch nicht. Checkdisk wiederum fragt, ob die Bereitstellung aufgehoben werden soll. Ist das in Ordnung?

Nach einem Kopierversuch von der SSD auf eine andere Platte hat plötzlich das Dateisystem der SSD von NTFS auf RAW gewechselt. Ich kann alles einsehen, aber nichts mehr kopieren.
 
Zuletzt bearbeitet :

Martin Gut

Urgestein
Mitglied seit
Sep 5, 2020
Beiträge
5.617
Punkte
113
Als erstes ist es vor solchen Basteleien immer die wichtigen Arbeitsdaten zu sichern. Dann ist man auf der sicheren Seite, falls etwas schief läuft. Die Software kann man sich meist problemlos neu herunter laden. Ein komplettes Backup kann man natürlich auch machen, damit sicher nichts vergessen geht. Wenn man das aktuelle System nicht reparieren kann, bringt einem das zurückspielen des alten Systems auch wenig. Daher würde ich mich auf das Sichern der Daten konzentrieren. Ich kopiere dafür einfach den ganzen Benutzerordner. Es gibt aber noch einzelne Programme, die ihre Daten an anderen Orten abspeichern.

Je nach Backupprogramm kann man auch aus einem Backup einzelne Daten zurück holen. Das ist aber meist recht umständlich.

Was das Betriebssystem mit den Laufwerksbuchstaben gewurstelt hat, sehe ich nicht. Das ist aber auch nicht so wichtig und lässt sich bei Bedarf einfach anpassen. Normalerweise wählt ein Betriebssystem für die eigene Partition den Buchstaben C: und vergibt an neue Laufwerke Buchstaben in aufsteigender Reihenfolge. Wenn man eine SSD/HD in einen anderen PC einbaut, Laufwerke nur zeitweise anschliesst und USB-Sticks wechselt, kommt dieses System gerne etwas durcheinander weil der Buchstabe eines Laufwerks auch noch an ein anderes vergeben wurde. Bei Arbeiten an der Partitionierung der Festplatte muss man sich immer am Laufwerkstyp und den Positionen und Grössen der Partition orientieren und nicht an den Buchstaben.

Danach würde ich versuchen, das System von unten nach oben zu kontrollieren und wenn nötig frisch aufzubauen.

Als erstes muss die SSD vom PC erkannt werden und im BIOS erscheinen, so dass man sie als Bootlaufwerk auswählen kann. So weit scheint es bei dir ja noch ungefähr zu funktionieren. Mit CrystalDiskInfo kann man testen, ob die SSD selbst funktioniert und sieht, was für Fehler möglicherweise aufgetaucht sind.

Wenn das Laufwerk erkannt wird, sucht das BIOS nach einem Bootsektor. Darin ist vermerkt, wo startbare Betriebssysteme installiert sind. Vermutlich liegt hier irgend ein Fehler vor, so dass kein Betriebssystem gefunden wird. Somit ist der nächste Schritt, den Bootsektor zu überprüfen und zu reparieren.

In jeder Partition steht am Anfang das Verzeichnis. Möglicherweise ist auch hier im Dateisystem etwas beschädigt, so dass Windows beim Booten nicht mehr alle nötigen Dateien findet. Das Dateisystem überprüfen wäre daher auch wichtig.

Erst dann käme die Überprüfung der Systemdateien von Windows.
 

Fleder

Mitglied
Mitglied seit
Nov 16, 2019
Beiträge
40
Punkte
8
Als erstes ist es vor solchen Basteleien immer die wichtigen Arbeitsdaten zu sichern. Dann ist man auf der sicheren Seite, falls etwas schief läuft. Die Software kann man sich meist problemlos neu herunter laden. Ein komplettes Backup kann man natürlich auch machen, damit sicher nichts vergessen geht. Wenn man das aktuelle System nicht reparieren kann, bringt einem das zurückspielen des alten Systems auch wenig. Daher würde ich mich auf das Sichern der Daten konzentrieren. Ich kopiere dafür einfach den ganzen Benutzerordner. Es gibt aber noch einzelne Programme, die ihre Daten an anderen Orten abspeichern.

Je nach Backupprogramm kann man auch aus einem Backup einzelne Daten zurück holen. Das ist aber meist recht umständlich.

Was das Betriebssystem mit den Laufwerksbuchstaben gewurstelt hat, sehe ich nicht. Das ist aber auch nicht so wichtig und lässt sich bei Bedarf einfach anpassen. Normalerweise wählt ein Betriebssystem für die eigene Partition den Buchstaben C: und vergibt an neue Laufwerke Buchstaben in aufsteigender Reihenfolge. Wenn man eine SSD/HD in einen anderen PC einbaut, Laufwerke nur zeitweise anschliesst und USB-Sticks wechselt, kommt dieses System gerne etwas durcheinander weil der Buchstabe eines Laufwerks auch noch an ein anderes vergeben wurde. Bei Arbeiten an der Partitionierung der Festplatte muss man sich immer am Laufwerkstyp und den Positionen und Grössen der Partition orientieren und nicht an den Buchstaben.

Danach würde ich versuchen, das System von unten nach oben zu kontrollieren und wenn nötig frisch aufzubauen.

Als erstes muss die SSD vom PC erkannt werden und im BIOS erscheinen, so dass man sie als Bootlaufwerk auswählen kann. So weit scheint es bei dir ja noch ungefähr zu funktionieren. Mit CrystalDiskInfo kann man testen, ob die SSD selbst funktioniert und sieht, was für Fehler möglicherweise aufgetaucht sind.

Wenn das Laufwerk erkannt wird, sucht das BIOS nach einem Bootsektor. Darin ist vermerkt, wo startbare Betriebssysteme installiert sind. Vermutlich liegt hier irgend ein Fehler vor, so dass kein Betriebssystem gefunden wird. Somit ist der nächste Schritt, den Bootsektor zu überprüfen und zu reparieren.

In jeder Partition steht am Anfang das Verzeichnis. Möglicherweise ist auch hier im Dateisystem etwas beschädigt, so dass Windows beim Booten nicht mehr alle nötigen Dateien findet. Das Dateisystem überprüfen wäre daher auch wichtig.

Erst dann käme die Überprüfung der Systemdateien von Windows.
Danke für die ausführlichen Erklärungen.

Es ist sporadisch möglich, Windows zu booten. Allerdings kommt dann nach etwa 30 Sekunden der Bluescreen mit besten WHEA Fehler. Also sollte der Bootsektor passen, nehme ich an.
 

Martin Gut

Urgestein
Mitglied seit
Sep 5, 2020
Beiträge
5.617
Punkte
113
Ja. Wenn es manchmal läuft und manchmal nicht, ist natürlich schwer zu sagen, woran es liegt.

Wenn es mal wieder startet, würde ich das Dateisystem überprüfen. Dafür gehst du in die Datenträgerverwaltung und rechts-klickst das Systemlaufwerk. Im erscheinenden Menu klickst du Eigenschaften und wählst dort die Registerkarte Tools und dann Fehlerüberprüfung.
 

Fleder

Mitglied
Mitglied seit
Nov 16, 2019
Beiträge
40
Punkte
8
Ja. Wenn es manchmal läuft und manchmal nicht, ist natürlich schwer zu sagen, woran es liegt.

Wenn es mal wieder startet, würde ich das Dateisystem überprüfen. Dafür gehst du in die Datenträgerverwaltung und rechts-klickst das Systemlaufwerk. Im erscheinenden Menu klickst du Eigenschaften und wählst dort die Registerkarte Tools und dann Fehlerüberprüfung.
Bei der Prüfung kommt auch immer wieder der WHEA Fehler.

Ich habe mir jetzt eine neue SSD und ein Gehäuse mit USB Anbindung gekauft. Ich versuche mal, ob sich die alte SSD via USB booten lässt und stabil läuft.

Wäre das ein sicheres Zeichen für ein Problem auf dem Motherboard oder könnte trotzdem etwas an der SSD selbst sein?
 

Martin Gut

Urgestein
Mitglied seit
Sep 5, 2020
Beiträge
5.617
Punkte
113
Wäre das ein sicheres Zeichen für ein Problem auf dem Motherboard oder könnte trotzdem etwas an der SSD selbst sein?
Probiere es einfach einmal. Booten über USB ist eher schwieriger als direkt verbaut. Da können wieder neue Probleme auftauchen. Spekulieren was dann in welchem Fall ist oder nicht, bringt momentan wenig.
 

Ghoster52

Urgestein
Mitglied seit
Nov 29, 2021
Beiträge
623
Punkte
63
Standort
Rottal-Inn
Meine Vermutung ist, Windoof hat sich selbst durch das Update zerschossen (Datei-Fehler).
Das ist leider nicht unüblich & selten, eines der wichtigen Oktober-Updates ist auch bei mir schief gelaufen,
hab ewig versucht es zu "reparieren", weil es keine Downloads und Updates mehr gemacht hat...
Lange Rede kurzer Sinn, platt gemacht und neu aufgesetzt (is leider so wenn man kein Backup gemacht hat,
ein drüber bügeln mit Einstellungen beibehalten hat auch die Fehler des Systems mit übernommen).
Ich versuche mal, ob sich die alte SSD via USB booten lässt
Endet meist auch im Bluescreen, hätte ich auch mal versucht, die M.2 SSD wollte einfach nicht im USB-Gehäuse starten.
Zugriff auf die Daten der SSD war jedoch möglich.

Auf jeden Fall würde ich die rumzickende SSD erst mal auf Fehler prüfen...
 

Fleder

Mitglied
Mitglied seit
Nov 16, 2019
Beiträge
40
Punkte
8
So. Bei Einbau in ein USB Gehäuse startet er gar nicht. Ich komm nicht mal ins BIOS.
Bleibt einem irgendwann im Bootvorgang stehen.

Ich kopiere jetzt mit cmd nach und nach Daten in Sicherheit. Aber ich habe das Gefühl bei größeren Dateien steigt die gleich aus.

Jetzt meinte ein Freund, dass es Überhitzung sein könnte. Da muss ja trotzdem ein defekt dahinter stecken. Man benötigt doch nicht zwingend einen Kühler für eine SSD, oder? Vor allem in meinem sehr kalten Keller.
 

Tronado

Urgestein
Mitglied seit
Mai 11, 2019
Beiträge
1.100
Punkte
84
Standort
Köln
Hast du irgendetwas übertaktet? Stell im BIOS mal alles auf Auto zurück und mach beim RAM XMP aus und starte neu.
Bei grenzwertigem RAM-Takt passieren manchmal seltsame Sachen. Ausprobieren, aber wahrscheinlich SSD defekt, wie du vermutest.
 

Fleder

Mitglied
Mitglied seit
Nov 16, 2019
Beiträge
40
Punkte
8
Hast du irgendetwas übertaktet? Stell im BIOS mal alles auf Auto zurück und mach beim RAM XMP aus und starte neu.
Bei grenzwertigem RAM-Takt passieren manchmal seltsame Sachen. Ausprobieren, aber wahrscheinlich SSD defekt, wie du vermutest.
Alles ohne Übertaktung und ohne xmp.

Ich hoffe nur, dass nicht doch noch das Motherboard das Problem ist.
 

Tronado

Urgestein
Mitglied seit
Mai 11, 2019
Beiträge
1.100
Punkte
84
Standort
Köln
Einen weiteren M.2 Slot hast du ausprobiert? Oder gibt's nur einen?
 
Oben Unten